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Centralized decision making (rank aggregation) 

�  Several agents judge a set of items 
�  A collective decision has to be made 
�  From the individuals’ rankings to a 

single ranking  
�  Respecting the judges’ preferences as 

much as possible 

�  Examples: 
¡  Web search engines ranking web pages 
¡  Cameras ranking the plausible 

interpretations of an object 
¡  A hiring committee 
¡  Recommender systems 
¡  Friends deciding where to go for dinner 
¡  Political elections 

�  Environment: judges’ 
preferences (or polls) 

�  Goal: collective preference 
ranking 

�  Actions: choose an 
aggregation method 

�  Uncertainty: over the 
rankings 

�  Centralized approach to 
achieve consensus or 
compromise 
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A simple example: friends choosing a dinner 

�  They want to eat the same meal 
¡  Pasta, main dish, dessert, drink 

�  5 options for each  
   è 54 = 625 possible dinners 
�  Each friend has his own preferences 

over the possible dinners 
�  We need to choose one of them 
�  How do we model their preferences?  
�  How do we choose the single meal they 

will all eat? 
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These scenarios are more and more frequent 

�  People are connected and want 
to take decisions with their 
friends or peers 

�  Online social networks 
�  Influences among agents 
�  Manipulations 
�  Not just people, also “things” 

¡  50 billion connected by 2020 
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More formal setting 

�  From 
¡  M candidates 
¡  N agents 
¡  For each agent, a preference order over the candidates 

�  we want to get 
¡  A single ordering of the candidates (social welfare function) 
¡  Or at least a “winning” candidate (social choice function) 

�  such that 
¡  the preferences of the agents are “considered” 

�  We can exploit concepts and techniques from voting 
theory (social choice) 
¡  After all, it looks like an election! 
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Voting rules (social choice functions) 

�  Plurality: one vote for each agent, score is number of 
votes 

�  Borda: each agent give full ranking, score depend on 
the position on the ranking 

�  Approval: each agent approves some candidates, 
score is number of approvals 

�  K-approval: each agent approves k candidates  
�  Also many others 

¡  Kemeny, Single Transferrable Vote, Veto, Copeland, Minimax, 
Range, Schulze, Banks, Slater, Bucklin, Dogson, … 

 
Duke University, Feb.13, 2015 



Plurality 

�  Vote: 1 candidate 
�  Result: candidate(s) with the most vote(s) 
�  Example:  

¡  6 voters  
¡  Candidates:  

Winner 
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Borda 
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Approval 
  

1 voter 1 voter 1 voter 1 voters 1 voter 

4 

3

3 

1 

Scores 
Winner 
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2-approval 
  

1 voter 1 voter 1 voter 1 voters 1 voter 

4 

3

2 

1 

Scores 
Winner 
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Which social choice function should we choose? 

�  With 2 candidates, easy: majority! 
�  With more than 2 candidates, look at their properties 
�  Examples of properties: 

¡  We don’t want one friend to be always deciding the dinner, 
independently of what the other friends say (non-dictatorship) 

¡  If everybody says that dinner A is preferred to dinner B, we 
don’t want B to be chosen (Pareto-efficiency) 

¡  Between A and B, the fact that A is chosen, or B, or none, 
should depend only on how the friends ordered A and B 
(independence of irrelevant alternatives) 
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Which social choice function should we choose? 

�  With 2 candidates, easy: majority! 
�  With more than 2 candidates, look at their properties 
�  Examples: 

¡  We don’t want one friend to be always deciding the dinner, 
independently of what the other friends say (non-dictatorship) 

¡  If everybody says that dinner A is preferred to dinner B, we don’t 
want B to be chosen (Pareto-efficiency) 

¡  Between A and B, the fact that A is chosen, or B, or none, should 
depend only on how the friends ordered A and B (independence of 
irrelevant alternatives) 

�  Unfortunately …. No voting rule has these  
    three properties!  

¡  Kenneth Arrow, Nobel in economics, 1972 
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Another desirable property: strategy-proofness 

�  A social choice function is strategy-proof if agents 
cannot manipulate the result 

�  Manipulation: misreporting his preferences in order 
to get a better result 
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Manipulation 

49% 20% 20% 11% 

Plurality 

49% 20% 20% 11% 

Plurality 
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Again not possible 

�  Unfortunately …. all social choice functions are 
manipulable! 
¡  Unless we accept dictatoriality or some candidate that can 

never win 
¡  Gibbard-Sattherwite theorems, 1975 
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Is it difficult to (check if we can) manipulate? 

�  We consider computational difficulty 
¡  Exponential time to figure out how to 

manipulate, knowing how the other agents 
will vote, in the worst case 

¡  Easy when it takes always polynomial time 
�  It depends on the voting rule 

¡  Easy for Plurality, Borda, and Approval 
¡  Difficult for other rules, like STV 

�  We could use voting rules where it is 
computationally difficult to (check if 
we can) manipulate! 
¡  So we mitigate the impossibility result 
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Is it computationally easy to compute the 
winner? 

�  Yes, for most of the rules 
¡  Plurality, Borda, approval, … 

�  But not for all 
¡  Example: Kemeny rule  
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Multiple issues 

�  Until now we have considered voting over one 
issue only 

�  Now we consider several issues 
�  Example:  

¡  3 referendum (yes/no) 
¡  Each voter has to give his preferences over triples of yes and 

no 
¡  Such as: YYY>NNN>YNY>YNN>etc. 

�  With k issues, k-tuples (2k if binary issues) 
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Paradox of multiple elections 

�  13 voters are asked to each vote yes or no on 3 
issues: 
¡  3 voters each vote for YNN, NYN, NNY 
¡  1 voter votes for YYY, YYN, YNY, NYY 
¡  No voter votes for NNN 

�  Majority on each issue: the winner is NNN! 
¡  Each issue has 7 out of 13 votes for no 

 
è not reasonable to vote independently over the 
features 

Duke University, Feb.13, 2015 



Plurality on combinations 

�  Ask each voter for her most preferred combination 
and apply plurality 
¡  Avoids the paradox, computationally light 
¡  Almost random decisions 
¡  Example: 10 binary issues, 20 voters è 210 = 1024 

combinations to vote for but only 20 voters, so very high 
probability that no combination receives more than one vote 
è tie-breaking rule decides everything 

�  Similar also for voting rules that use only a small 
part of the voters’ preferences (ex.: k-approval with 
small k) 
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Other rules on combinations 

�  Vote on combinations and use other voting rules that 
use the whole preference ordering on combinations 

�  Avoids the arbitrariness problem of plurality 
�  Not feasible when there are large domains  
�  Example:  

¡  Borda (needs the whole preference ordering) 
¡  6 binary issues è 26=64 possible combinations è each voter 

has to choose amongst 64! possible ballots 
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Sequential voting 

�  Vote separately on each issue, but do so sequentially  
�  This gives voters the opportunity to make their vote 

for one issue depend on the decisions on previous 
issues 
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Condorcet losers 

�  Condorcet loser (CL): candidate that loses against 
any other candidate in a pairwise contest 

�  Electing a CL is very bad, but Plurality sometimes 
elects it 

�  Example:  
¡  2 votes for X > Y > Z 
¡  2 votes for Y > X > Z 
¡  3 votes for Z > X > Y 
¡  Z is the Plurality winner and the Condorcet loser 
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Sequential voting and Condorcet losers 

�  Sequential voting avoids the problem of electing 
Condorcet losers 

�  Thm.: Sequential plurality voting over binary issues 
never elects a Condorcet loser 
¡  Proof: Consider the election for the final issue. The winning 

combination cannot be a CL, since it wins at least against the 
other combination that was still possible after the penultimate 
election 

¡  [Lacy, Niou, J. of Theoretical Politics, 2000] 

�  But no guarantee that sequential voting elects the 
Condorcet winner (Condorcet consistency) 
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How to express preferences compactly over a set 
of related items? 

�  When there are many candidates, unfeasible to rank 
them all 
¡  Think of the dinner example: 625 possible dinners! 

�  We need a compact way to say what we prefer 
�  Two main options 

¡  Quantitative (ex. Soft constraints) 
÷ Decide on a scale, ex. from 0 to 5, where higher number means 

more preferred 
÷ Evaluate some parts of the dinner over this scale 

¡  Qualitative (ex. CP-nets) 
÷ Dependence between items, total order on the options for each 

item 
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Example: fuzzy constraints 

Lunch time=         13 
Meal =              meat 
Wine =             white 
Swimming time=   14 

     Decision A 

pref(A)=min(0.3,0)=0 

Lunch time =         12  
Meal =                 fish 
Wine =              white 
Swimming time =   14 

     Decision B 

pref(B)=min(1,1)=1 

{12,	
  13}	
   {14,	
  15}	
  

Lunch	
  
/me	
  

Swimming	
  	
  
/me	
  

(12,	
  15)	
  à	
  1	
  

(12,	
  14)	
  à	
  1	
   	
  	
  (13,	
  14)	
  à	
  0	
  

	
  	
  (13,	
  15)	
  à	
  1	
  

{fish,	
  meat}	
   {white,	
  red}	
  

meal	
   wine	
  

(fish,	
  red)	
  à	
  0.8	
  

(fish,	
  white)	
  à	
  1	
   (meat,white)	
  à	
  0.3	
  

(meat,	
  red)	
  à	
  0.7	
  

Preference of a decision: minimal preference of its parts 
Aim: to find a decision with maximal preference 
Preference values: between 0 and 1 



Example: CP-net  

fish>meat	
  

peaches	
  >	
  strawberries	
  

Main 
course      Wine 

        fish  white > 
red 

       meat  red > 
white 

Main	
  	
  
course	
  

Fruit	
  

Wine	
  

Fish,	
  white,	
  peaches	
  

Fish,	
  red,	
  peaches	
   Fish,	
  white,	
  berries	
  

Fish,	
  red,	
  berries	
  

meat,	
  red,	
  peaches	
  

meat,	
  red,	
  berries	
  meat,	
  white,	
  peaches	
  

meat,	
  white,	
  berries	
  

Op/mal	
  solu/on	
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Soft constraints vs. CP-nets 

all all  some some 
difficult easy difficult easy 

easy easy difficult difficult 

difficult difficult for 
weighted, 
easy for fuzzy 

difficult easy 

difficult easy easy easy 
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Preference orderings 
 
 

Find an optimal decision 
 
 

Compare two decisions 
 

Find the next best  
Decision 

 
Check if a decision  

is optimal 

Soft CSPs Tree-like 
soft CSPS 

CP-nets Acyclic CP-
nets 



Sequential voting with soft constraints 

�  Agents expressing preferences via soft constraints  
�  Over a common set of decisions/options 

¡  options = complete variable assignments 
�  Same vars and var domains for all agents, different soft constraints 
�  Profile = preferences of all agents 

¡  Explicit profile: preference orderings are given 
¡  Implicit profile: compact representation of the preferences 

�  We will select a decision using a voting rule 
¡  Decision = solution for the agents soft constraint satisfaction problems (sof CSP) 
¡  Voting rule: function from an explicit profile to a decision 

�  In the dinner example: 
¡  Each friend has his own soft CSP to express the preferences over the dinners 
¡  We need to select one dinner over the 625 possible ones 
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Agent 1 Agent 2 Agent 3 

Dinner example using plurality 

Pasta 

Drink 

Pesto 1 
Tom   0.7 

(Pesto, Beer) 1 
(Pesto,Wine) 0.5 
(Tom ,Beer)  0.7 
(Tom,Wine)   0.3 

Beer 1 
Wine 0.7 

Pasta 

Drink 

Pesto 0.9 
Tom   1 

(Pesto, Beer) 1 
(Pesto,Wine) 0.9 
(Tom ,Beer)  0.9 
(Tom,Wine)   0.9 

Beer 1 
Wine 1 

Pasta 

Drink 

Pesto 1 
Tom   0.3 

(Pesto, Beer) 1 
(Pesto,Wine) 0.3 
(Tom ,Beer)  0.3 
(Tom,Wine)   1 

Beer 1 
Wine  1 

Plurality Pasta 
   = 
Pesto 

Pesto 1 
Tom   0 

Pesto 0.9 
Tom   0 

Pesto 1 
Tom   0 

(Pesto, Beer) 1 
(Pesto,Wine) 0.5 
(Tom ,Beer)  0 
(Tom,Wine)   0 

(Pesto, Beer) 1 
(Pesto,Wine) 0.9 
(Tom ,Beer)  0 
(Tom,Wine)   0 

(Pesto, Beer) 1 
(Pesto,Wine) 0.3 
(Tom ,Beer)  0 
(Tom,Wine)   0 

Beer 1 
Wine 0.5 

Beer 1 
Wine 0.9 

Beer 1 
Wine  0.3 

Plurality Drink 
   = 
Beer 

Winner 
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Sequential voting with CP-nets 

�  n voters, voting by giving a CP-net each 
¡  Same variables, different dependency graph and CP tables 

�  Compatible CP-nets: there exists a linear order on 
the variables that is compatible with the 
dependency graph of all CP-nets (that is, it 
completes the DAG) 

�  Then vote sequentially in this order 
�  Thm.: Under these assumptions, sequential voting 

is Condorcet consistent if all local voting rules are 
¡  (Lang and Xia, Math. Social Sciences, 2009)  
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ROVER 1 ROVER 2 ROVER 3 

Example 

WHER
E 

WHA
T 

Loc-A >Loc-B   

WHER
E 

WHA
T 

Loc-B> Loc-A   

St2>St1 

WHER
E 

WHA
T 

Loc-A >Loc-B   

Plurality WHERE 
   = 

Loc-A 

Loc-A     Loc-A Loc-A  

Plurality 

WHAT 
   = 

Image 

Winner 

3 Rovers must decide: 
•  Where to go: Location A or Location B 
•  What to do: Analyze a rock or Take a picture 
•  Which station to downlink the data to: Station 1 or Station 2 

Image >Analyze   

DLIN
K 

St1 >St2   

DLIN
K 

DLIN
K 

St2>St1 

Loc-A: Image > Analyze 
Loc-B: Analyze> Image 

Plurality 

DLINK 
     = 
   St2 

Analyze >Image   Image >Analyze   

Loc-A: Analyze> Image 
Loc-B: Image> Analyze 
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Sequential voting:  
soft constraints vs. CP-nets 
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�  With soft constraints 
¡  Solving and projecting at each step 
¡  Tractable in some case (ex. Tree) 
¡  But no requirement on compatibility among SCSPs 

�  With CP-nets 
¡  Directional dependency links 
¡  Compatibility is required 
¡  No solving/projecting effort 


